<!doctype html> <!--[if lt IE 7]> <html class="no-js lt-ie9 lt-ie8 lt-ie7" lang="en-US"> <![endif]--> <!--[if IE 7]>    <html class="no-js lt-ie9 lt-ie8" lang="en-US"> <![endif]--> <!--[if IE 8]>    <html class="no-js lt-ie9" lang="en-US"> <![endif]--> <!--[if IE 9]>    <html class="no-js lt-ie10" lang="en-US"> <![endif]--> <!--[if gt IE 8]><!--> <html class="no-js" lang="en-US"> <!--<![endif]--><head><meta http-equiv="Content-Type" content="text/html; charset=UTF-8" /><meta name='viewport' content='width=device-width, initial-scale=1, user-scalable=yes' /><link rel="profile" href="https://gmpg.org/xfn/11" /><link rel="pingback" href="https://middleeasy.com/xmlrpc.php" /><link rel="manifest" href="/superpwa-manifest.json"><meta name="theme-color" content="#ee0000"><meta name="theme-color" content="#ee2d00"><meta name="msapplication-navbutton-color" content="#ee2d00"><meta name="apple-mobile-web-app-status-bar-style" content="#ee2d00"><title>Floyd Mayweather Offers To Fund The Funeral Of George Floyd &ndash; MiddleEasy.com</title><link rel="stylesheet" href="https://middleeasy.com/wp-content/cache/min/1/a3d06cc67f79dae96afff2f46649242d.css" data-minify="1" /> <script>window.adthrive = window.adthrive || {};
window.adthrive.cmd = window.adthrive.cmd || [];
window.adthrive.host = 'ads.adthrive.com';
window.adthrive.plugin = 'adthrive-ads-1.0.37';
window.adthrive.threshold = Math.floor(Math.random() * 100 + 1);

(function() {
	var script = document.createElement('script');
	script.async = true;
	script.type = 'text/javascript';
	script.src = 'https://ads.adthrive.com/sites/5db21d0d0454ff0c3880719d/ads.min.js?threshold=' + window.adthrive.threshold;
	var node = document.getElementsByTagName('script')[0];
	node.parentNode.insertBefore(script, node);
})();</script> <meta name="description" content="Floyd Mayweather has been bothered by what is going on in the world right now. That is why he has offered to pay for the funeral of George Floyd." /><meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><link rel="canonical" href="https://middleeasy.com/boxing/floyd-mayweather-funeral-george/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Floyd Mayweather Offers To Fund The Funeral Of George Floyd &ndash; MiddleEasy.com" /><meta property="og:description" content="Floyd Mayweather has been bothered by what is going on in the world right now. That is why he has offered to pay for the funeral of George Floyd." /><meta property="og:url" content="https://middleeasy.com/boxing/floyd-mayweather-funeral-george/" /><meta property="og:site_name" content="MiddleEasy.com" /><meta property="article:publisher" content="https://www.facebook.com/middleeasydotcom/" /><meta property="article:tag" content="Boxing" /><meta property="article:tag" content="floyd mayweather" /><meta property="article:tag" content="George Floyd" /><meta property="article:tag" content="Justice For George Floyd" /><meta property="article:section" content="Boxing" /><meta property="article:published_time" content="2020-06-02T13:51:31+00:00" /><meta property="article:modified_time" content="2020-06-02T14:05:36+00:00" /><meta property="og:updated_time" content="2020-06-02T14:05:36+00:00" /><meta property="fb:app_id" content="2276965822516781" /><meta property="og:image" content="https://middleeasy.com/wp-content/uploads/2020/06/pixlr-20200602011811988-copy-1400x733-1.jpg" /><meta property="og:image:secure_url" content="https://middleeasy.com/wp-content/uploads/2020/06/pixlr-20200602011811988-copy-1400x733-1.jpg" /><meta property="og:image:width" content="1400" /><meta property="og:image:height" content="733" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:description" content="Floyd Mayweather has been bothered by what is going on in the world right now. That is why he has offered to pay for the funeral of George Floyd." /><meta name="twitter:title" content="Floyd Mayweather Offers To Fund The Funeral Of George Floyd &ndash; MiddleEasy.com" /><meta name="twitter:site" content="@MiddleEasy" /><meta name="twitter:image" content="https://middleeasy.com/wp-content/uploads/2020/06/pixlr-20200602011811988-copy-1400x733-1.jpg" /><meta name="twitter:creator" content="@aquabuddha7" /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//fonts.gstatic.com' /><link rel='dns-prefetch' href='//www.google-analytics.com' /><link rel='dns-prefetch' href='//secure.gravatar.com' /><link rel='dns-prefetch' href='//www.facebook.com' /><link rel='dns-prefetch' href='//onesignal.com' /><link rel="alternate" type="application/rss+xml" title="MiddleEasy.com &raquo; Feed" href="https://middleeasy.com/feed/" /><link rel="alternate" type="application/rss+xml" title="MiddleEasy.com &raquo; Comments Feed" href="https://middleeasy.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="MiddleEasy.com &raquo; Floyd Mayweather Offers To Fund The Funeral Of George Floyd Comments Feed" href="https://middleeasy.com/boxing/floyd-mayweather-funeral-george/feed/" /><style type="text/css">img.wp-smiley,img.emoji{display:inline!important;border:none!important;box-shadow:none!important;height:1em!important;width:1em!important;margin:0 .07em!important;vertical-align:-0.1em!important;background:none!important;padding:0!important}</style><link crossorigin="anonymous" rel='stylesheet' id='jeg_customizer_font-css' href='//fonts.googleapis.com/css?family=Roboto%3Aregular%2C500%2Citalic%2C500italic%2C700%7COpen+Sans%3Aregular%2C600%2C700&#038;display=swap&#038;ver=1.2.3' type='text/css' media='all' /> <script type='text/javascript' src='https://middleeasy.com/wp-content/cache/busting/1/wp-includes/js/jquery/jquery-1.12.4-wp.js'></script> <link rel='https://api.w.org/' href='https://middleeasy.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://middleeasy.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://middleeasy.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.4.1" /><link rel='shortlink' href='https://middleeasy.com/?p=106469' /><style type="text/css">.aawp .aawp-tb__row--highlight{background-color:#256aaf}.aawp .aawp-tb__row--highlight{color:#fff}.aawp .aawp-tb__row--highlight a{color:#fff}</style><script src="https://www.google.com/recaptcha/api.js?hl=en_US" async defer></script> <meta http-equiv="Content-Security-Policy" content="upgrade-insecure-requests;block-all-mixed-content" /><style type="text/css">.td-post-featured-video .essb_totalcount{color:#fff!important}.essb-mobile-sharebar,.essb-mobile-sharepoint,.essb-mobile-sharebottom{display:none}</style> <script type="text/javascript">var essb_settings = {"ajax_url":"https:\/\/middleeasy.com\/wp-admin\/admin-ajax.php","essb3_nonce":"20819713e3","essb3_plugin_url":"https:\/\/middleeasy.com\/wp-content\/plugins\/easy-social-share-buttons3","essb3_stats":false,"essb3_ga":false,"essb3_ga_mode":"simple","blog_url":"https:\/\/middleeasy.com\/","essb3_postfloat_stay":false,"post_id":106469};</script> <meta name="onesignal" content="wordpress-plugin" /> <link rel="amphtml" href="https://middleeasy.com/boxing/floyd-mayweather-funeral-george/amp/"><script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"Organization","@id":"https:\/\/middleeasy.com\/#organization","url":"https:\/\/middleeasy.com\/","name":"MiddleEasy: MMA News","logo":{"@type":"ImageObject","url":"https:\/\/middleeasy.com\/wp-content\/uploads\/2020\/06\/middleeasy-logo.png"},"sameAs":["https:\/\/www.facebook.com\/middleeasydotcom\/","https:\/\/twitter.com\/MiddleEasy","https:\/\/www.youtube.com\/middleeasytv\/","https:\/\/www.instagram.com\/middleeasy\/"]}</script> <script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"WebSite","@id":"https:\/\/middleeasy.com\/#website","url":"https:\/\/middleeasy.com\/","name":"MiddleEasy: MMA News","potentialAction":{"@type":"SearchAction","target":"https:\/\/middleeasy.com\/?s={search_term_string}","query-input":"required name=search_term_string"}}</script> <link rel="icon" href="https://middleeasy.com/wp-content/uploads/2020/06/cropped-me-icon-1-32x32.png" sizes="32x32" /><link rel="icon" href="https://middleeasy.com/wp-content/uploads/2020/06/cropped-me-icon-1-192x192.png" sizes="192x192" /><link rel="apple-touch-icon" href="https://middleeasy.com/wp-content/uploads/2020/06/cropped-me-icon-1-180x180.png" /><meta name="msapplication-TileImage" content="https://middleeasy.com/wp-content/uploads/2020/06/cropped-me-icon-1-270x270.png" /> <script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-42513671-1', 'auto');
  ga('send', 'pageview');</script> <style id="jeg_dynamic_css" type="text/css" data-type="jeg_custom-css">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</style><style type="text/css">.no_thumbnail{display:none}</style><noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player,[data-lazy-src]{display:none!important}</style></noscript></head><body data-rsssl=1 class="post-template-default single single-post postid-106469 single-format-standard wp-embed-responsive aawp-custom jeg_toggle_dark jeg_single_tpl_1 jnews jsc_normal elementor-default"><div class="jeg_ad jeg_ad_top jnews_header_top_ads"><div class='ads-wrapper '></div></div><div class="jeg_viewport"><div class="jeg_header_wrapper"><div class="jeg_header_instagram_wrapper"></div><div class="jeg_header normal"><div class="jeg_topbar jeg_container dark"><div class="container"><div class="jeg_nav_row"><div class="jeg_nav_col jeg_nav_left jeg_nav_grow"><div class="item_wrap jeg_nav_alignleft"><div class="jeg_nav_item"><ul class="jeg_menu jeg_top_menu"><li id="menu-item-64315" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-64315"><a href="https://middleeasy.com/about-middleeasy/">About</a></li><li id="menu-item-100861" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-100861"><a href="https://middleeasy.com/syndication/">Free Content</a></li><li id="menu-item-64314" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-64314"><a href="https://middleeasy.com/writers-wanted/">Writers Wanted</a></li><li id="menu-item-64316" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-64316"><a href="https://middleeasy.com/contact-us/">Contact</a></li></ul></div></div></div><div class="jeg_nav_col jeg_nav_center jeg_nav_normal"><div class="item_wrap jeg_nav_aligncenter"></div></div><div class="jeg_nav_col jeg_nav_right jeg_nav_normal"><div class="item_wrap jeg_nav_alignright"><div class="jeg_nav_item socials_widget jeg_social_icon_block nobg"> <a href="https://www.facebook.com/middleeasydotcom/" target='_blank' class="jeg_facebook"><i class="fa fa-facebook"></i> </a><a href="https://twitter.com/MiddleEasy" target='_blank' class="jeg_twitter"><i class="fa fa-twitter"></i> </a><a href="https://www.youtube.com/middleeasytv/" target='_blank' class="jeg_youtube"><i class="fa fa-youtube-play"></i> </a><a href="https://www.instagram.com/middleeasy/" target='_blank' class="jeg_instagram"><i class="fa fa-instagram"></i> </a></div></div></div></div></div></div><div class="jeg_bottombar jeg_navbar jeg_container jeg_navbar_wrapper jeg_navbar_normal jeg_navbar_dark"><div class="container"><div class="jeg_nav_row"><div class="jeg_nav_col jeg_nav_left jeg_nav_normal"><div class="item_wrap jeg_nav_alignleft"><div class="jeg_nav_item jeg_logo jeg_desktop_logo"><div class="site-title"> <a href="https://middleeasy.com/" style="padding: 0 0 0 0;"> <img class='jeg_logo_img' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" data-lazy-srcset="https://middleeasy.com/wp-content/uploads/2020/06/middleeasylogo.png 1x, https://middleeasy.com/wp-content/uploads/2020/06/middleeasy-logo.png 2x" alt="MiddleEasy: UFC &amp; MMA News" data-light-src="https://middleeasy.com/wp-content/uploads/2020/06/middleeasylogo.png" data-light-srcset="https://middleeasy.com/wp-content/uploads/2020/06/middleeasylogo.png 1x, https://middleeasy.com/wp-content/uploads/2020/06/middleeasy-logo.png 2x" data-dark-src="" data-dark-srcset=" 1x, 2x" data-lazy-src="https://middleeasy.com/wp-content/uploads/2020/06/middleeasylogo.png"><noscript><img class='jeg_logo_img' src="https://middleeasy.com/wp-content/uploads/2020/06/middleeasylogo.png" srcset="https://middleeasy.com/wp-content/uploads/2020/06/middleeasylogo.png 1x, https://middleeasy.com/wp-content/uploads/2020/06/middleeasy-logo.png 2x" alt="MiddleEasy: UFC &amp; MMA News"data-light-src="https://middleeasy.com/wp-content/uploads/2020/06/middleeasylogo.png" data-light-srcset="https://middleeasy.com/wp-content/uploads/2020/06/middleeasylogo.png 1x, https://middleeasy.com/wp-content/uploads/2020/06/middleeasy-logo.png 2x" data-dark-src="" data-dark-srcset=" 1x, 2x"></noscript> </a></div></div><div class="jeg_main_menu_wrapper"><div class="jeg_nav_item jeg_mainmenu_wrap"><ul class="jeg_menu jeg_main_menu jeg_menu_style_4" data-animation="slide"><li id="menu-item-104755" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-104755 bgnav" data-item-row="default"><a href="https://middleeasy.com/mma-news/">MMA News</a></li><li id="menu-item-62830" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62830 bgnav" data-item-row="default"><a href="https://middleeasy.com/category/mma-rumors/">Rumors</a></li><li id="menu-item-41986" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-41986 bgnav" data-item-row="default"><a href="https://middleeasy.com/category/street-fights/">Street Fights</a></li><li id="menu-item-93739" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-93739 bgnav" data-item-row="default"><a href="https://middleeasy.com/reviews/">MMA Reviews</a></li><li id="menu-item-63038" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-63038 bgnav" data-item-row="default"><a href="https://middleeasy.com/category/videos/">Videos</a></li><li id="menu-item-64101" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-64101 bgnav" data-item-row="default"><a href="https://middleeasy.com/category/top-lists/">MMA Top Lists</a></li><li id="menu-item-64050" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-64050 bgnav" data-item-row="default"><a href="#">More</a><ul class="sub-menu"><li id="menu-item-62863" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62863 bgnav" data-item-row="default"><a href="https://middleeasy.com/category/podcast/">Podcast</a></li><li id="menu-item-64102" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-64102 bgnav" data-item-row="default"><a href="https://middleeasy.com/category/science/">Science</a></li><li id="menu-item-62832" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62832 bgnav" data-item-row="default"><a href="https://middleeasy.com/category/entertainment/">Entertainment</a></li><li id="menu-item-62831" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62831 bgnav" data-item-row="default"><a href="https://middleeasy.com/category/gaming/">Gaming</a></li><li id="menu-item-64117" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-64117 bgnav" data-item-row="default"><a href="https://middleeasy.com/category/trump-mma/">Trump MMA</a></li></ul></li></ul></div></div></div></div><div class="jeg_nav_col jeg_nav_center jeg_nav_normal"><div class="item_wrap jeg_nav_aligncenter"></div></div><div class="jeg_nav_col jeg_nav_right jeg_nav_grow"><div class="item_wrap jeg_nav_alignright"><div class="jeg_nav_item jeg_search_wrapper search_icon jeg_search_popup_expand"> <a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a><form action="https://middleeasy.com/" method="get" class="jeg_search_form" target="_top"> <input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off"> <button type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button></form><div class="jeg_search_result jeg_search_hide with_result"><div class="search-result-wrapper"></div><div class="search-link search-noresult"> No Result</div><div class="search-link search-all-button"> <i class="fa fa-search"></i> View All Result</div></div></div></div></div></div></div></div></div></div><div class="jeg_header_sticky"><div class="sticky_blankspace"></div><div class="jeg_header normal"><div class="jeg_container"><div data-mode="fixed" class="jeg_stickybar jeg_navbar jeg_navbar_wrapper jeg_navbar_normal jeg_navbar_dark"><div class="container"><div class="jeg_nav_row"><div class="jeg_nav_col jeg_nav_left jeg_nav_grow"><div class="item_wrap jeg_nav_alignleft"><div class="jeg_main_menu_wrapper"><div class="jeg_nav_item jeg_mainmenu_wrap"><ul class="jeg_menu jeg_main_menu jeg_menu_style_4" data-animation="slide"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-104755 bgnav" data-item-row="default"><a href="https://middleeasy.com/mma-news/">MMA News</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62830 bgnav" data-item-row="default"><a href="https://middleeasy.com/category/mma-rumors/">Rumors</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-41986 bgnav" data-item-row="default"><a href="https://middleeasy.com/category/street-fights/">Street Fights</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-93739 bgnav" data-item-row="default"><a href="https://middleeasy.com/reviews/">MMA Reviews</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-63038 bgnav" data-item-row="default"><a href="https://middleeasy.com/category/videos/">Videos</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-64101 bgnav" data-item-row="default"><a href="https://middleeasy.com/category/top-lists/">MMA Top Lists</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-64050 bgnav" data-item-row="default"><a href="#">More</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62863 bgnav" data-item-row="default"><a href="https://middleeasy.com/category/podcast/">Podcast</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-64102 bgnav" data-item-row="default"><a href="https://middleeasy.com/category/science/">Science</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62832 bgnav" data-item-row="default"><a href="https://middleeasy.com/category/entertainment/">Entertainment</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62831 bgnav" data-item-row="default"><a href="https://middleeasy.com/category/gaming/">Gaming</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-64117 bgnav" data-item-row="default"><a href="https://middleeasy.com/category/trump-mma/">Trump MMA</a></li></ul></li></ul></div></div></div></div><div class="jeg_nav_col jeg_nav_center jeg_nav_normal"><div class="item_wrap jeg_nav_aligncenter"></div></div><div class="jeg_nav_col jeg_nav_right jeg_nav_normal"><div class="item_wrap jeg_nav_alignright"><div class="jeg_nav_item socials_widget jeg_social_icon_block nobg"> <a href="https://www.facebook.com/middleeasydotcom/" target='_blank' class="jeg_facebook"><i class="fa fa-facebook"></i> </a><a href="https://twitter.com/MiddleEasy" target='_blank' class="jeg_twitter"><i class="fa fa-twitter"></i> </a><a href="https://www.youtube.com/middleeasytv/" target='_blank' class="jeg_youtube"><i class="fa fa-youtube-play"></i> </a><a href="https://www.instagram.com/middleeasy/" target='_blank' class="jeg_instagram"><i class="fa fa-instagram"></i> </a></div><div class="jeg_separator separator4"></div><div class="jeg_nav_item jeg_search_wrapper search_icon jeg_search_popup_expand"> <a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a><form action="https://middleeasy.com/" method="get" class="jeg_search_form" target="_top"> <input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off"> <button type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button></form><div class="jeg_search_result jeg_search_hide with_result"><div class="search-result-wrapper"></div><div class="search-link search-noresult"> No Result</div><div class="search-link search-all-button"> <i class="fa fa-search"></i> View All Result</div></div></div></div></div></div></div></div></div></div></div><div class="jeg_navbar_mobile_wrapper"><div class="jeg_navbar_mobile" data-mode="scroll"><div class="jeg_mobile_bottombar jeg_mobile_midbar jeg_container dark"><div class="container"><div class="jeg_nav_row"><div class="jeg_nav_col jeg_nav_left jeg_nav_normal"><div class="item_wrap jeg_nav_alignleft"><div class="jeg_nav_item"> <a href="#" class="toggle_btn jeg_mobile_toggle"><i class="fa fa-bars"></i></a></div></div></div><div class="jeg_nav_col jeg_nav_center jeg_nav_grow"><div class="item_wrap jeg_nav_aligncenter"><div class="jeg_nav_item jeg_mobile_logo"><div class="site-title"> <a href="https://middleeasy.com/"> <img class='jeg_logo_img' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" data-lazy-srcset="https://middleeasy.com/wp-content/uploads/2020/06/middleeasylogo.png 1x, https://middleeasy.com/wp-content/uploads/2020/06/middleeasy-logo.png 2x" alt="MiddleEasy: MMA News" data-light-src="https://middleeasy.com/wp-content/uploads/2020/06/middleeasylogo.png" data-light-srcset="https://middleeasy.com/wp-content/uploads/2020/06/middleeasylogo.png 1x, https://middleeasy.com/wp-content/uploads/2020/06/middleeasy-logo.png 2x" data-dark-src="https://middleeasy.com/wp-content/uploads/2020/06/middleeasylogo.png" data-dark-srcset="https://middleeasy.com/wp-content/uploads/2020/06/middleeasylogo.png 1x, https://middleeasy.com/wp-content/uploads/2020/06/middleeasy-logo.png 2x" data-lazy-src="https://middleeasy.com/wp-content/uploads/2020/06/middleeasylogo.png"><noscript><img class='jeg_logo_img' src="https://middleeasy.com/wp-content/uploads/2020/06/middleeasylogo.png" srcset="https://middleeasy.com/wp-content/uploads/2020/06/middleeasylogo.png 1x, https://middleeasy.com/wp-content/uploads/2020/06/middleeasy-logo.png 2x" alt="MiddleEasy: MMA News"data-light-src="https://middleeasy.com/wp-content/uploads/2020/06/middleeasylogo.png" data-light-srcset="https://middleeasy.com/wp-content/uploads/2020/06/middleeasylogo.png 1x, https://middleeasy.com/wp-content/uploads/2020/06/middleeasy-logo.png 2x" data-dark-src="https://middleeasy.com/wp-content/uploads/2020/06/middleeasylogo.png" data-dark-srcset="https://middleeasy.com/wp-content/uploads/2020/06/middleeasylogo.png 1x, https://middleeasy.com/wp-content/uploads/2020/06/middleeasy-logo.png 2x"></noscript> </a></div></div></div></div><div class="jeg_nav_col jeg_nav_right jeg_nav_normal"><div class="item_wrap jeg_nav_alignright"><div class="jeg_nav_item jeg_search_wrapper jeg_search_popup_expand"> <a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a><form action="https://middleeasy.com/" method="get" class="jeg_search_form" target="_top"> <input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off"> <button type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button></form><div class="jeg_search_result jeg_search_hide with_result"><div class="search-result-wrapper"></div><div class="search-link search-noresult"> No Result</div><div class="search-link search-all-button"> <i class="fa fa-search"></i> View All Result</div></div></div></div></div></div></div></div></div><div class="sticky_blankspace" style="height: 60px;"></div></div><div class="post-wrapper"><div class="post-wrap"><div class="jeg_main "><div class="jeg_container"><div class="jeg_content jeg_singlepage"><div class="container"><div class="jeg_ad jeg_article jnews_article_top_ads"><div class='ads-wrapper '></div></div><div class="row"><div class="jeg_main_content col-md-8"><div class="jeg_inner_content"><div class="jeg_breadcrumbs jeg_breadcrumb_container"><div id="breadcrumbs"><span class=""> <a href="https://middleeasy.com">Home</a> </span><i class="fa fa-angle-right"></i><span class="breadcrumb_last_link"> <a href="https://middleeasy.com/category/boxing/">Boxing</a> </span></div></div><div class="entry-header"><h1 class="jeg_post_title">Floyd Mayweather Offers To Fund The Funeral Of George Floyd</h1><h2 class="jeg_post_subtitle">Floyd Mayweather Will Pay For George Floyd&#039;s Funeral</h2><div class="jeg_meta_container"><div class="jeg_post_meta jeg_post_meta_1"><div class="meta_left"><div class="jeg_meta_author"> <img alt='Derek Hall' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2080'%3E%3C/svg%3E" data-lazy-srcset='https://secure.gravatar.com/avatar/1bc1b654bfecfe1a8ce2eaa1043b56cd?s=160&#038;d=mm&#038;r=g 2x' class='avatar avatar-80 photo' height='80' width='80' data-lazy-src="https://secure.gravatar.com/avatar/1bc1b654bfecfe1a8ce2eaa1043b56cd?s=80&#038;d=mm&#038;r=g" /><noscript><img alt='Derek Hall' src='https://secure.gravatar.com/avatar/1bc1b654bfecfe1a8ce2eaa1043b56cd?s=80&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/1bc1b654bfecfe1a8ce2eaa1043b56cd?s=160&#038;d=mm&#038;r=g 2x' class='avatar avatar-80 photo' height='80' width='80' /></noscript> <span class="meta_text">by</span> <a href="https://middleeasy.com/author/derekhall/">Derek Hall</a></div><div class="jeg_meta_date"> <a href="https://middleeasy.com/boxing/floyd-mayweather-funeral-george/">June 2, 2020</a></div><div class="jeg_meta_category"> <span><span class="meta_text">in</span> <a href="https://middleeasy.com/category/boxing/" rel="category tag">Boxing</a>, <a href="https://middleeasy.com/category/featured/" rel="category tag">Featured</a> </span></div></div><div class="meta_right"></div></div></div></div><div class="jeg_featured featured_image"><a href="https://middleeasy.com/wp-content/uploads/2020/06/pixlr-20200602011811988-copy-1400x733-1.jpg"><div class="thumbnail-container animate-lazy" style="padding-bottom:50%"><img width="750" height="375" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" class="lazyload wp-post-image" alt="Floyd Mayweather" data-src="https://middleeasy.com/wp-content/uploads/2020/06/pixlr-20200602011811988-copy-1400x733-1-750x375.jpg" data-sizes="auto" data-expand="700" /></div><p class="wp-caption-text">Photos via Instagram @floydmayweather @george.__.floyd</p></a></div><div class="jeg_ad jeg_article jnews_content_top_ads "><div class='ads-wrapper '></div></div><div class="entry-content no-share"><div class="jeg_share_button share-float jeg_sticky_share clearfix share-normal"></div><div class="content-inner "><div class="essb_links essb_counters essb_displayed_top essb_share essb_template_rainbow-retina essb_1155712628 print-no" id="essb_displayed_top_1155712628" data-essb-postid="106469" data-essb-position="top" data-essb-button-style="button" data-essb-template="rainbow-retina" data-essb-counter-pos="hidden" data-essb-url="https://middleeasy.com/boxing/floyd-mayweather-funeral-george/" data-essb-twitter-url="https://middleeasy.com/boxing/floyd-mayweather-funeral-george/" data-essb-instance="1155712628"><ul class="essb_links_list"><li class="essb_item essb_totalcount_item" style="display: none !important;" data-essb-hide-till="50" data-counter-pos="hidden"><span class="essb_totalcount essb_t_l_big essb_total_icon essb_icon_share-tiny" title="" data-shares-text="shares"><span class="essb_t_nb">1<span class="essb_t_nb_after">shares</span></span></span></li><li class="essb_item essb_link_facebook nolightbox"> <a href="https://www.facebook.com/sharer/sharer.php?u=https://middleeasy.com/boxing/floyd-mayweather-funeral-george/&t=Floyd+Mayweather+Offers+To+Fund+The+Funeral+Of+George+Floyd" title="" onclick="essb.window(&#39;https://www.facebook.com/sharer/sharer.php?u=https://middleeasy.com/boxing/floyd-mayweather-funeral-george/&t=Floyd+Mayweather+Offers+To+Fund+The+Funeral+Of+George+Floyd&#39;,&#39;facebook&#39;,&#39;1155712628&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox"><span class="essb_icon essb_icon_facebook"></span><span class="essb_network_name">Facebook</span></a><span class="essb_counter_hidden" data-cnt="" style="display: none;" data-cnt-short=""></span></li><li class="essb_item essb_link_twitter nolightbox"> <a href="#" title="" onclick="essb.window(&#39;https://twitter.com/intent/tweet?text=Floyd+Mayweather+Offers+To+Fund+The+Funeral+Of+George+Floyd&amp;url=https://middleeasy.com/boxing/floyd-mayweather-funeral-george/&amp;counturl=https://middleeasy.com/boxing/floyd-mayweather-funeral-george/&amp;related=MiddleEasy&amp;via=MiddleEasy&amp;hashtags=Boxing,floydmayweather,GeorgeFloyd,JusticeForGeorgeFloyd&#39;,&#39;twitter&#39;,&#39;1155712628&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox"><span class="essb_icon essb_icon_twitter"></span><span class="essb_network_name">Twitter</span></a><span class="essb_counter_hidden" data-cnt="1" style="display: none;" data-cnt-short=""></span></li><li class="essb_item essb_link_reddit nolightbox"> <a href="https://reddit.com/submit?url=https://middleeasy.com/boxing/floyd-mayweather-funeral-george/&amp;title=Floyd+Mayweather+Offers+To+Fund+The+Funeral+Of+George+Floyd" title="" onclick="essb.window(&#39;http://reddit.com/submit?url=https://middleeasy.com/boxing/floyd-mayweather-funeral-george/&amp;title=Floyd+Mayweather+Offers+To+Fund+The+Funeral+Of+George+Floyd&#39;,&#39;reddit&#39;,&#39;1155712628&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox"><span class="essb_icon essb_icon_reddit"></span><span class="essb_network_name">Reddit</span></a><span class="essb_counter_hidden" data-cnt="" style="display: none;" data-cnt-short=""></span></li><li class="essb_item essb_link_flipboard nolightbox"> <a href="https://share.flipboard.com/bookmarklet/popout?url=https://middleeasy.com/boxing/floyd-mayweather-funeral-george/&title=Floyd+Mayweather+Offers+To+Fund+The+Funeral+Of+George+Floyd" title="" onclick="essb.window(&#39;https://share.flipboard.com/bookmarklet/popout?url=https://middleeasy.com/boxing/floyd-mayweather-funeral-george/&title=Floyd+Mayweather+Offers+To+Fund+The+Funeral+Of+George+Floyd&#39;,&#39;flipboard&#39;,&#39;1155712628&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox"><span class="essb_icon essb_icon_flipboard"></span><span class="essb_network_name">Flipboard</span></a></li><li class="essb_item essb_link_more nolightbox"> <a href="#" title="" onclick="essb.toggle_more(&#39;1155712628&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox"><span class="essb_icon essb_icon_more"></span><span class="essb_network_name essb_noname"></span></a></li><li class="essb_item essb_link_linkedin nolightbox essb_after_more"> <a href="https://www.linkedin.com/shareArticle?mini=true&amp;ro=true&amp;trk=EasySocialShareButtons&amp;title=Floyd+Mayweather+Offers+To+Fund+The+Funeral+Of+George+Floyd&amp;url=https://middleeasy.com/boxing/floyd-mayweather-funeral-george/" title="" onclick="essb.window(&#39;https://www.linkedin.com/shareArticle?mini=true&amp;ro=true&amp;trk=EasySocialShareButtons&amp;title=Floyd+Mayweather+Offers+To+Fund+The+Funeral+Of+George+Floyd&amp;url=https://middleeasy.com/boxing/floyd-mayweather-funeral-george/&#39;,&#39;linkedin&#39;,&#39;1155712628&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox"><span class="essb_icon essb_icon_linkedin"></span><span class="essb_network_name">LinkedIn</span></a><span class="essb_counter_hidden" data-cnt="" style="display: none;" data-cnt-short=""></span></li><li class="essb_item essb_link_pinterest nolightbox essb_after_more"> <a href="#" title="" onclick="essb.pinterest_picker(&#39;1155712628&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox"><span class="essb_icon essb_icon_pinterest"></span><span class="essb_network_name">Pinterest</span></a><span class="essb_counter_hidden" data-cnt="" style="display: none;" data-cnt-short=""></span></li><li class="essb_item essb_link_less nolightbox essb_after_more"> <a href="#" title="" onclick="essb.toggle_less(&#39;1155712628&#39;); return false;" target="_blank" rel="nofollow"><span class="essb_icon essb_icon_less"></span><span class="essb_network_name"></span></a></li></ul></div><p>The world is immensely complicated right now, in the wake of the death of George Floyd. Now boxing great <strong>Floyd Mayweather</strong> has offered his assistance to George&#8217;s family during this difficult time.</p><p>It has been just over a month since Minneapolis police allegedly caused the death of 59-year old George Floyd. This has resulted in <strong>a ton of tension throughout the nation</strong>, as riots and protests have broken out throughout the country. This has even caused various fighters to <a href="https://middleeasy.com/mma-news/jon-jones-albuquerque-protesters/">stop vandalism</a>, <a href="https://middleeasy.com/mma-news/israel-adesanya-speech/">protest</a>, or try to <a href="https://middleeasy.com/mma-news/chuck-liddell-fights-rally/">keep the peace</a>.</p><blockquote class="instagram-media" data-instgrm-captioned data-instgrm-permalink="https://www.instagram.com/p/B9QSSGsl5Po/?utm_source=ig_embed&amp;utm_campaign=loading" data-instgrm-version="12" style=" background:#FFF; border:0; border-radius:3px; box-shadow:0 0 1px 0 rgba(0,0,0,0.5),0 1px 10px 0 rgba(0,0,0,0.15); margin: 1px; max-width:500px; min-width:326px; padding:0; width:99.375%; width:-webkit-calc(100% - 2px); width:calc(100% - 2px);"><div style="padding:16px;"> <a href="https://www.instagram.com/p/B9QSSGsl5Po/?utm_source=ig_embed&amp;utm_campaign=loading" style=" background:#FFFFFF; line-height:0; padding:0 0; text-align:center; text-decoration:none; width:100%;" target="_blank"></p><div style=" display: flex; flex-direction: row; align-items: center;"><div style="background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 40px; margin-right: 14px; width: 40px;"></div><div style="display: flex; flex-direction: column; flex-grow: 1; justify-content: center;"><div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; margin-bottom: 6px; width: 100px;"></div><div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; width: 60px;"></div></div></div><div style="padding: 19% 0;"></div><div style="display:block; height:50px; margin:0 auto 12px; width:50px;"><svg width="50px" height="50px" viewBox="0 0 60 60" version="1.1" xmlns="https://www.w3.org/2000/svg" xmlns:xlink="https://www.w3.org/1999/xlink"><g stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"><g transform="translate(-511.000000, -20.000000)" fill="#000000"><g><path d="M556.869,30.41 C554.814,30.41 553.148,32.076 553.148,34.131 C553.148,36.186 554.814,37.852 556.869,37.852 C558.924,37.852 560.59,36.186 560.59,34.131 C560.59,32.076 558.924,30.41 556.869,30.41 M541,60.657 C535.114,60.657 530.342,55.887 530.342,50 C530.342,44.114 535.114,39.342 541,39.342 C546.887,39.342 551.658,44.114 551.658,50 C551.658,55.887 546.887,60.657 541,60.657 M541,33.886 C532.1,33.886 524.886,41.1 524.886,50 C524.886,58.899 532.1,66.113 541,66.113 C549.9,66.113 557.115,58.899 557.115,50 C557.115,41.1 549.9,33.886 541,33.886 M565.378,62.101 C565.244,65.022 564.756,66.606 564.346,67.663 C563.803,69.06 563.154,70.057 562.106,71.106 C561.058,72.155 560.06,72.803 558.662,73.347 C557.607,73.757 556.021,74.244 553.102,74.378 C549.944,74.521 548.997,74.552 541,74.552 C533.003,74.552 532.056,74.521 528.898,74.378 C525.979,74.244 524.393,73.757 523.338,73.347 C521.94,72.803 520.942,72.155 519.894,71.106 C518.846,70.057 518.197,69.06 517.654,67.663 C517.244,66.606 516.755,65.022 516.623,62.101 C516.479,58.943 516.448,57.996 516.448,50 C516.448,42.003 516.479,41.056 516.623,37.899 C516.755,34.978 517.244,33.391 517.654,32.338 C518.197,30.938 518.846,29.942 519.894,28.894 C520.942,27.846 521.94,27.196 523.338,26.654 C524.393,26.244 525.979,25.756 528.898,25.623 C532.057,25.479 533.004,25.448 541,25.448 C548.997,25.448 549.943,25.479 553.102,25.623 C556.021,25.756 557.607,26.244 558.662,26.654 C560.06,27.196 561.058,27.846 562.106,28.894 C563.154,29.942 563.803,30.938 564.346,32.338 C564.756,33.391 565.244,34.978 565.378,37.899 C565.522,41.056 565.552,42.003 565.552,50 C565.552,57.996 565.522,58.943 565.378,62.101 M570.82,37.631 C570.674,34.438 570.167,32.258 569.425,30.349 C568.659,28.377 567.633,26.702 565.965,25.035 C564.297,23.368 562.623,22.342 560.652,21.575 C558.743,20.834 556.562,20.326 553.369,20.18 C550.169,20.033 549.148,20 541,20 C532.853,20 531.831,20.033 528.631,20.18 C525.438,20.326 523.257,20.834 521.349,21.575 C519.376,22.342 517.703,23.368 516.035,25.035 C514.368,26.702 513.342,28.377 512.574,30.349 C511.834,32.258 511.326,34.438 511.181,37.631 C511.035,40.831 511,41.851 511,50 C511,58.147 511.035,59.17 511.181,62.369 C511.326,65.562 511.834,67.743 512.574,69.651 C513.342,71.625 514.368,73.296 516.035,74.965 C517.703,76.634 519.376,77.658 521.349,78.425 C523.257,79.167 525.438,79.673 528.631,79.82 C531.831,79.965 532.853,80.001 541,80.001 C549.148,80.001 550.169,79.965 553.369,79.82 C556.562,79.673 558.743,79.167 560.652,78.425 C562.623,77.658 564.297,76.634 565.965,74.965 C567.633,73.296 568.659,71.625 569.425,69.651 C570.167,67.743 570.674,65.562 570.82,62.369 C570.966,59.17 571,58.147 571,50 C571,41.851 570.966,40.831 570.82,37.631"></path></g></g></g></svg></div><div style="padding-top: 8px;"><div style=" color:#3897f0; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:550; line-height:18px;"> View this post on Instagram</div></div><div style="padding: 12.5% 0;"></div><div style="display: flex; flex-direction: row; margin-bottom: 14px; align-items: center;"><div><div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(0px) translateY(7px);"></div><div style="background-color: #F4F4F4; height: 12.5px; transform: rotate(-45deg) translateX(3px) translateY(1px); width: 12.5px; flex-grow: 0; margin-right: 14px; margin-left: 2px;"></div><div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(9px) translateY(-18px);"></div></div><div style="margin-left: 8px;"><div style=" background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 20px; width: 20px;"></div><div style=" width: 0; height: 0; border-top: 2px solid transparent; border-left: 6px solid #f4f4f4; border-bottom: 2px solid transparent; transform: translateX(16px) translateY(-4px) rotate(30deg)"></div></div><div style="margin-left: auto;"><div style=" width: 0px; border-top: 8px solid #F4F4F4; border-right: 8px solid transparent; transform: translateY(16px);"></div><div style=" background-color: #F4F4F4; flex-grow: 0; height: 12px; width: 16px; transform: translateY(-4px);"></div><div style=" width: 0; height: 0; border-top: 8px solid #F4F4F4; border-left: 8px solid transparent; transform: translateY(-4px) translateX(8px);"></div></div></div><p></a></p><p style=" margin:8px 0 0 0; padding:0 4px;"> <a href="https://www.instagram.com/p/B9QSSGsl5Po/?utm_source=ig_embed&amp;utm_campaign=loading" style=" color:#000; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px; text-decoration:none; word-wrap:break-word;" target="_blank">They told me to reach for the stars and I landed on the moon&#8230; #TinMan #MoonSwag #TBE #TMT #London</a></p><p style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; line-height:17px; margin-bottom:0; margin-top:8px; overflow:hidden; padding:8px 0 7px; text-align:center; text-overflow:ellipsis; white-space:nowrap;">A post shared by <a href="https://www.instagram.com/floydmayweather/?utm_source=ig_embed&amp;utm_campaign=loading" style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px;" target="_blank"> Floyd Mayweather</a> (@floydmayweather) on <time style=" font-family:Arial,sans-serif; font-size:14px; line-height:17px;" datetime="2020-03-03T02:18:54+00:00">Mar 2, 2020 at 6:18pm PST</time></p></div></blockquote><p></p><p>Now another member of the combat sports community is doing his part to help out during this tough time. According to <a href="https://www.espn.com/boxing/story/_/id/29252860/floyd-mayweather-pay-george-floyd-funeral-services">reports</a>, world champion boxer Floyd Mayweather has stepped up to <strong>cover the costs of the funeral for George Floyd.</strong> It was not something he wanted to bring attention to, but his manager Leonard Ellerbe confirmed the rumors.</p><blockquote class="pullquote align-center"><p>&#8220;He’ll probably get mad at me for saying that, but yes, (Mayweather) is definitely paying for the funeral,” he said. “Floyd has done these kind of things over the last 20 years.&#8221;</p></blockquote><p>This is <strong>a massively kind gesture from Floyd,</strong> without a doubt. It can be said with a fair degree of certainty, that George&#8217;s family has been having a wild time since the tragic loss of their family member, and the subsequent media storm. It must be at least some level of relief to know that this will be taken care of.</p><p>There have been some pretty big critics of some of the things Floyd Mayweather has done over the years, and rightfully so. However this is not the first time that he has done something to this effect. Nevertheless it is important to note the times that <strong>he goes above and beyond to support the culture</strong> in a time of need.</p><div class="widget_text awac-wrapper"><div class="widget_text awac widget custom_html-2"><div class="textwidget custom-html-widget">For more MMA News, Rumors and Updates follow the Red Monster on <a href="https://www.facebook.com/middleeasydotcom/">Facebook</a>, <a href="https://twitter.com/MiddleEasy">Twitter</a>, <a href="https://youtube.com/middleeasytv/">YouTube</a> and <a href="https://www.instagram.com/middleeasy/">Instagram</a></div></div></div><div class="essb_links essb_counters essb_displayed_bottom essb_share essb_template_rainbow-retina essb_249816309 print-no" id="essb_displayed_bottom_249816309" data-essb-postid="106469" data-essb-position="bottom" data-essb-button-style="button" data-essb-template="rainbow-retina" data-essb-counter-pos="hidden" data-essb-url="https://middleeasy.com/boxing/floyd-mayweather-funeral-george/" data-essb-twitter-url="https://middleeasy.com/boxing/floyd-mayweather-funeral-george/" data-essb-instance="249816309"><ul class="essb_links_list"><li class="essb_item essb_totalcount_item" style="display: none !important;" data-essb-hide-till="50" data-counter-pos="hidden"><span class="essb_totalcount essb_t_l_big essb_total_icon essb_icon_share-tiny" title="" data-shares-text="shares"><span class="essb_t_nb">1<span class="essb_t_nb_after">shares</span></span></span></li><li class="essb_item essb_link_facebook nolightbox"> <a href="https://www.facebook.com/sharer/sharer.php?u=https://middleeasy.com/boxing/floyd-mayweather-funeral-george/&t=Floyd+Mayweather+Offers+To+Fund+The+Funeral+Of+George+Floyd" title="" onclick="essb.window(&#39;https://www.facebook.com/sharer/sharer.php?u=https://middleeasy.com/boxing/floyd-mayweather-funeral-george/&t=Floyd+Mayweather+Offers+To+Fund+The+Funeral+Of+George+Floyd&#39;,&#39;facebook&#39;,&#39;249816309&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox"><span class="essb_icon essb_icon_facebook"></span><span class="essb_network_name">Facebook</span></a><span class="essb_counter_hidden" data-cnt="" style="display: none;" data-cnt-short=""></span></li><li class="essb_item essb_link_twitter nolightbox"> <a href="#" title="" onclick="essb.window(&#39;https://twitter.com/intent/tweet?text=Floyd+Mayweather+Offers+To+Fund+The+Funeral+Of+George+Floyd&amp;url=https://middleeasy.com/boxing/floyd-mayweather-funeral-george/&amp;counturl=https://middleeasy.com/boxing/floyd-mayweather-funeral-george/&amp;related=MiddleEasy&amp;via=MiddleEasy&amp;hashtags=Boxing,floydmayweather,GeorgeFloyd,JusticeForGeorgeFloyd&#39;,&#39;twitter&#39;,&#39;249816309&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox"><span class="essb_icon essb_icon_twitter"></span><span class="essb_network_name">Twitter</span></a><span class="essb_counter_hidden" data-cnt="1" style="display: none;" data-cnt-short=""></span></li><li class="essb_item essb_link_reddit nolightbox"> <a href="https://reddit.com/submit?url=https://middleeasy.com/boxing/floyd-mayweather-funeral-george/&amp;title=Floyd+Mayweather+Offers+To+Fund+The+Funeral+Of+George+Floyd" title="" onclick="essb.window(&#39;http://reddit.com/submit?url=https://middleeasy.com/boxing/floyd-mayweather-funeral-george/&amp;title=Floyd+Mayweather+Offers+To+Fund+The+Funeral+Of+George+Floyd&#39;,&#39;reddit&#39;,&#39;249816309&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox"><span class="essb_icon essb_icon_reddit"></span><span class="essb_network_name">Reddit</span></a><span class="essb_counter_hidden" data-cnt="" style="display: none;" data-cnt-short=""></span></li><li class="essb_item essb_link_flipboard nolightbox"> <a href="https://share.flipboard.com/bookmarklet/popout?url=https://middleeasy.com/boxing/floyd-mayweather-funeral-george/&title=Floyd+Mayweather+Offers+To+Fund+The+Funeral+Of+George+Floyd" title="" onclick="essb.window(&#39;https://share.flipboard.com/bookmarklet/popout?url=https://middleeasy.com/boxing/floyd-mayweather-funeral-george/&title=Floyd+Mayweather+Offers+To+Fund+The+Funeral+Of+George+Floyd&#39;,&#39;flipboard&#39;,&#39;249816309&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox"><span class="essb_icon essb_icon_flipboard"></span><span class="essb_network_name">Flipboard</span></a></li><li class="essb_item essb_link_more nolightbox"> <a href="#" title="" onclick="essb.toggle_more(&#39;249816309&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox"><span class="essb_icon essb_icon_more"></span><span class="essb_network_name essb_noname"></span></a></li><li class="essb_item essb_link_linkedin nolightbox essb_after_more"> <a href="https://www.linkedin.com/shareArticle?mini=true&amp;ro=true&amp;trk=EasySocialShareButtons&amp;title=Floyd+Mayweather+Offers+To+Fund+The+Funeral+Of+George+Floyd&amp;url=https://middleeasy.com/boxing/floyd-mayweather-funeral-george/" title="" onclick="essb.window(&#39;https://www.linkedin.com/shareArticle?mini=true&amp;ro=true&amp;trk=EasySocialShareButtons&amp;title=Floyd+Mayweather+Offers+To+Fund+The+Funeral+Of+George+Floyd&amp;url=https://middleeasy.com/boxing/floyd-mayweather-funeral-george/&#39;,&#39;linkedin&#39;,&#39;249816309&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox"><span class="essb_icon essb_icon_linkedin"></span><span class="essb_network_name">LinkedIn</span></a><span class="essb_counter_hidden" data-cnt="" style="display: none;" data-cnt-short=""></span></li><li class="essb_item essb_link_pinterest nolightbox essb_after_more"> <a href="#" title="" onclick="essb.pinterest_picker(&#39;249816309&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox"><span class="essb_icon essb_icon_pinterest"></span><span class="essb_network_name">Pinterest</span></a><span class="essb_counter_hidden" data-cnt="" style="display: none;" data-cnt-short=""></span></li><li class="essb_item essb_link_less nolightbox essb_after_more"> <a href="#" title="" onclick="essb.toggle_less(&#39;249816309&#39;); return false;" target="_blank" rel="nofollow"><span class="essb_icon essb_icon_less"></span><span class="essb_network_name"></span></a></li></ul></div><div class="essb_break_scroll"></div><div class="jeg_post_tags"><span>Tags:</span> <a href="https://middleeasy.com/tag/boxing/" rel="tag">Boxing</a><a href="https://middleeasy.com/tag/floyd-mayweather/" rel="tag">floyd mayweather</a><a href="https://middleeasy.com/tag/george-floyd/" rel="tag">George Floyd</a><a href="https://middleeasy.com/tag/justice-for-george-floyd/" rel="tag">Justice For George Floyd</a></div></div></div><div class="jeg_ad jeg_article jnews_content_bottom_ads "><div class='ads-wrapper '></div></div><div class="jnews_prev_next_container"><div class="jeg_prevnext_post"> <a href="https://middleeasy.com/ufc-news/white-reacts-jones-title/" class="post prev-post"> <span class="caption">Previous Post</span><h3 class="post-title">Dana White Reacts To Jon Jones Vacating Title: &#8216;He&#8217;s Made Enough Money&#8217;</h3> </a> <a href="https://middleeasy.com/mma-news/bas-rutten-meltzers-wife/" class="post next-post"> <span class="caption">Next Post</span><h3 class="post-title">Bas Rutten Apparently Tried To Hit On Dave Meltzer&#8217;s Wife While He Was Drunk</h3> </a></div></div><div class="jnews_author_box_container "><div class="jeg_authorbox"><div class="jeg_author_image"> <img alt='Derek Hall' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2080'%3E%3C/svg%3E" data-lazy-srcset='https://secure.gravatar.com/avatar/1bc1b654bfecfe1a8ce2eaa1043b56cd?s=160&#038;d=mm&#038;r=g 2x' class='avatar avatar-80 photo' height='80' width='80' data-lazy-src="https://secure.gravatar.com/avatar/1bc1b654bfecfe1a8ce2eaa1043b56cd?s=80&#038;d=mm&#038;r=g" /><noscript><img alt='Derek Hall' src='https://secure.gravatar.com/avatar/1bc1b654bfecfe1a8ce2eaa1043b56cd?s=80&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/1bc1b654bfecfe1a8ce2eaa1043b56cd?s=160&#038;d=mm&#038;r=g 2x' class='avatar avatar-80 photo' height='80' width='80' /></noscript></div><div class="jeg_author_content"><h3 class="jeg_author_name"> <a href="https://middleeasy.com/author/derekhall/"> Derek Hall </a></h3><p class="jeg_author_desc"> Writer and interviewer for MMA, powerlifting, bodybuilding, strongman, and CrossFit. Opinions are strictly my own.</p><div class="jeg_author_socials"> <a target='_blank' href='http://fitnessvolt.com/author/derek' class='url'><i class='fa fa-globe'></i> </a> <a target='_blank' href="https://twitter.com/aquabuddha7" class='twitter'><i class='fa fa-twitter'></i> </a></div></div></div></div><div class="jnews_related_post_container"><div class="jeg_postblock_22 jeg_postblock jeg_module_hook jeg_pagination_disable jeg_col_2o3 jnews_module_106469_0_5ed692d4b0c98 " data-unique="jnews_module_106469_0_5ed692d4b0c98"><div class="jeg_block_heading jeg_block_heading_1 jeg_subcat_right"><h3 class="jeg_block_title"><span>Related<strong> Posts</strong></span></h3></div><div class="jeg_block_container"><div class="jeg_posts_wrap"><div class="jeg_posts jeg_load_more_flag"><article class="jeg_post jeg_pl_md_5 format-standard"><div class="jeg_thumb"> <a href="https://middleeasy.com/mma-news/chuck-liddell-fights-rally/"><div class="thumbnail-container animate-lazy size-715 "><img width="350" height="250" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" class="lazyload wp-post-image" alt="Chuck Liddell" data-src="https://middleeasy.com/wp-content/uploads/2020/06/pixlr-20200601133629014-copy-1400x733-1-350x250.jpg" data-sizes="auto" data-expand="700" /></div></a><div class="jeg_post_category"> <span><a href="https://middleeasy.com/category/mma-news/" class="category-mma-news">MMA News</a></span></div></div><div class="jeg_postblock_content"><h3 class="jeg_post_title"> <a href="https://middleeasy.com/mma-news/chuck-liddell-fights-rally/">Chuck Liddell Attempts To Break Up Fights At Huntington Beach Rally</a></h3><div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://middleeasy.com/mma-news/chuck-liddell-fights-rally/"><i class="fa fa-clock-o"></i> June 1, 2020</a></div></div></div></article><article class="jeg_post jeg_pl_md_5 format-standard"><div class="jeg_thumb"> <a href="https://middleeasy.com/mma-news/jon-jones-albuquerque-protesters/"><div class="thumbnail-container animate-lazy size-715 "><img width="350" height="250" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" class="lazyload wp-post-image" alt="Jon Jones" data-src="https://middleeasy.com/wp-content/uploads/2020/06/screenshot-20200601-115735-copy-1400x733-1-350x250.jpg" data-sizes="auto" data-expand="700" /></div></a><div class="jeg_post_category"> <span><a href="https://middleeasy.com/category/mma-news/" class="category-mma-news">MMA News</a></span></div></div><div class="jeg_postblock_content"><h3 class="jeg_post_title"> <a href="https://middleeasy.com/mma-news/jon-jones-albuquerque-protesters/">Jon Jones Snatches Spray Paint From &#8216;Punk A&#8211;&#8216; Albuquerque Protesters</a></h3><div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://middleeasy.com/mma-news/jon-jones-albuquerque-protesters/"><i class="fa fa-clock-o"></i> June 1, 2020</a></div></div></div></article><article class="jeg_post jeg_pl_md_5 format-standard"><div class="jeg_thumb"> <a href="https://middleeasy.com/boxing/tyson-fury-mike-tyson/"><div class="thumbnail-container animate-lazy size-715 "><img width="350" height="250" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" class="lazyload wp-post-image" alt="Tyson Fury" data-src="https://middleeasy.com/wp-content/uploads/2020/05/pixlr-20200527155929593-copy-1400x733-1-350x250.jpg" data-sizes="auto" data-expand="700" /></div></a><div class="jeg_post_category"> <span><a href="https://middleeasy.com/category/boxing/" class="category-boxing">Boxing</a></span></div></div><div class="jeg_postblock_content"><h3 class="jeg_post_title"> <a href="https://middleeasy.com/boxing/tyson-fury-mike-tyson/">Tyson Fury Reveals He Was Contacted For Boxing Match With Mike Tyson</a></h3><div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://middleeasy.com/boxing/tyson-fury-mike-tyson/"><i class="fa fa-clock-o"></i> May 27, 2020</a></div></div></div></article><article class="jeg_post jeg_pl_md_5 format-standard"><div class="jeg_thumb"> <a href="https://middleeasy.com/mma-news/jones-condemns-floyd-death/"><div class="thumbnail-container animate-lazy size-715 "><img width="350" height="250" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" class="lazyload wp-post-image" alt="Photo of Jon Jones via Instagram: @JonnyBones" data-src="https://middleeasy.com/wp-content/uploads/2020/05/pjimage-68--350x250.jpg" data-sizes="auto" data-expand="700" /></div></a><div class="jeg_post_category"> <span><a href="https://middleeasy.com/category/mma-news/" class="category-mma-news">MMA News</a></span></div></div><div class="jeg_postblock_content"><h3 class="jeg_post_title"> <a href="https://middleeasy.com/mma-news/jones-condemns-floyd-death/">Jon Jones Condemns George Floyd Death, Says Everyone Should Be &#8216;Pissed Off&#8217;</a></h3><div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://middleeasy.com/mma-news/jones-condemns-floyd-death/"><i class="fa fa-clock-o"></i> May 27, 2020</a></div></div></div></article><article class="jeg_post jeg_pl_md_5 format-standard"><div class="jeg_thumb"> <a href="https://middleeasy.com/boxing/mike-tyson-vitor-belfort/"><div class="thumbnail-container animate-lazy size-715 "><img width="350" height="250" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" class="lazyload wp-post-image" alt="Mike Tyson" data-src="https://middleeasy.com/wp-content/uploads/2020/05/pixlr-20200526131806043-copy-1400x733-1-350x250.jpg" data-sizes="auto" data-expand="700" /></div></a><div class="jeg_post_category"> <span><a href="https://middleeasy.com/category/boxing/" class="category-boxing">Boxing</a></span></div></div><div class="jeg_postblock_content"><h3 class="jeg_post_title"> <a href="https://middleeasy.com/boxing/mike-tyson-vitor-belfort/">Mike Tyson Trains With TRT Vitor Belfort Ahead Of Boxing Comeback</a></h3><div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://middleeasy.com/boxing/mike-tyson-vitor-belfort/"><i class="fa fa-clock-o"></i> May 27, 2020</a></div></div></div></article><article class="jeg_post jeg_pl_md_5 format-standard"><div class="jeg_thumb"> <a href="https://middleeasy.com/boxing/wanderlei-silva-offer-tyson/"><div class="thumbnail-container animate-lazy size-715 "><img width="350" height="250" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" class="lazyload wp-post-image" alt="Wanderlei Silva" data-src="https://middleeasy.com/wp-content/uploads/2020/05/pixlr-20200525235430463-copy-1400x733-1-350x250.jpg" data-sizes="auto" data-expand="700" /></div></a><div class="jeg_post_category"> <span><a href="https://middleeasy.com/category/bare-knuckle-boxing/" class="category-bare-knuckle-boxing">Bare Knuckle Boxing</a></span></div></div><div class="jeg_postblock_content"><h3 class="jeg_post_title"> <a href="https://middleeasy.com/boxing/wanderlei-silva-offer-tyson/">Wanderlei Silva Accepts $10 Million Offer To Fight Mike Tyson In Bare Knuckle FC</a></h3><div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://middleeasy.com/boxing/wanderlei-silva-offer-tyson/"><i class="fa fa-clock-o"></i> May 26, 2020</a></div></div></div></article></div></div><div class='module-overlay'><div class='preloader_type preloader_dot'><div class="module-preloader jeg_preloader dot"> <span></span><span></span><span></span></div><div class="module-preloader jeg_preloader circle"><div class="jnews_preloader_circle_outer"><div class="jnews_preloader_circle_inner"></div></div></div><div class="module-preloader jeg_preloader square"><div class="jeg_square"><div class="jeg_square_inner"></div></div></div></div></div></div><div class="jeg_block_navigation"><div class='navigation_overlay'><div class='module-preloader jeg_preloader'><span></span><span></span><span></span></div></div></div> <script>var jnews_module_106469_0_5ed692d4b0c98 = {"header_icon":"","first_title":"Related","second_title":" Posts","url":"","header_type":"heading_1","header_background":"","header_secondary_background":"","header_text_color":"","header_line_color":"","header_accent_color":"","header_filter_category":"","header_filter_author":"","header_filter_tag":"","header_filter_text":"All","post_type":"post","content_type":"all","number_post":"6","post_offset":0,"unique_content":"disable","include_post":"","exclude_post":106469,"include_category":"","exclude_category":"","include_author":"","include_tag":"534,537,38851,39094","exclude_tag":"","sort_by":"latest","date_format":"default","date_format_custom":"Y\/m\/d","force_normal_image_load":"","pagination_mode":"disable","pagination_nextprev_showtext":"","pagination_number_post":"6","pagination_scroll_limit":"2","boxed":"","boxed_shadow":"","el_id":"","el_class":"","scheme":"","column_width":"auto","title_color":"","accent_color":"","alt_color":"","excerpt_color":"","css":"","excerpt_length":20,"paged":1,"column_class":"jeg_col_2o3","class":"jnews_block_22"};</script> </div></div><div class="jnews_popup_post_container"></div><div class="jnews_comment_container"><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/boxing/floyd-mayweather-funeral-george/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://middleeasy.com/wp-comments-post.php" method="post" id="commentform" class="comment-form"><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label><textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p><p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p><p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p><div class="g-recaptcha" data-sitekey="6LfB-G4UAAAAAM8oxznlqLv4QSZcDE4DHcPNeS9q" data-theme="light"></div><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='106469' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p></form></div></div></div></div><div class="jeg_sidebar jeg_sticky_sidebar col-md-4"><div class="widget widget_jnews_module_block_1" id="jnews_module_block_1-2"><div class="jeg_postblock_1 jeg_postblock jeg_module_hook jeg_pagination_disable jeg_col_1o3 jnews_module_106469_1_5ed692d4b6ba5 " data-unique="jnews_module_106469_1_5ed692d4b6ba5"><div class="jeg_block_container jeg_load_more_flag"><div class="jeg_posts"><article class="jeg_post jeg_pl_lg_1 format-standard"><div class="jeg_thumb"> <a href="https://middleeasy.com/mma-news/10th-planet-burned-down/"><div class="thumbnail-container animate-lazy size-500 "><img width="360" height="180" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" class="lazyload wp-post-image" alt="10th Planet" data-src="https://middleeasy.com/wp-content/uploads/2020/06/pjimage-1--360x180.jpg" data-sizes="auto" data-expand="700" /></div></a><div class="jeg_post_category"> <span><a href="https://middleeasy.com/category/mma-news/" class="category-mma-news">MMA News</a></span></div></div><div class="jeg_postblock_content"><h3 property="headline" class="jeg_post_title"> <a href="https://middleeasy.com/mma-news/10th-planet-burned-down/">10th Planet Jiu Jitsu Long Beach Gym Burned Down During Protests</a></h3><div class="jeg_post_meta"><div class="jeg_meta_author"><span class="by">by</span> <a href="https://middleeasy.com/author/abhinav-kini/">Abhinav Kini</a></div><div class="jeg_meta_date"><a href="https://middleeasy.com/mma-news/10th-planet-burned-down/"><i class="fa fa-clock-o"></i> June 2, 2020</a></div></div><div class="jeg_post_excerpt"><p>The Long Beach gym of 10th Planet Jiu Jitsu was unfortunately burned down and destroyed. As Black Lives Matter protests...</p> <a href="https://middleeasy.com/mma-news/10th-planet-burned-down/" class="jeg_readmore">Read more</a></div></div></article><div class="jeg_postsmall"><article class="jeg_post jeg_pl_sm format-standard"><div class="jeg_thumb"> <a href="https://middleeasy.com/mma-news/bas-rutten-meltzers-wife/"><div class="thumbnail-container animate-lazy size-715 "><img width="120" height="86" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" class="lazyload wp-post-image" alt="Bas Rutten" data-src="https://middleeasy.com/wp-content/uploads/2020/06/pixlr-20200602120753270-copy-1400x733-1-120x86.jpg" data-sizes="auto" data-expand="700" /></div> </a></div><div class="jeg_postblock_content"><h3 class="jeg_post_title"> <a href="https://middleeasy.com/mma-news/bas-rutten-meltzers-wife/">Bas Rutten Apparently Tried To Hit On Dave Meltzer&#8217;s Wife While He Was Drunk</a></h3><div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://middleeasy.com/mma-news/bas-rutten-meltzers-wife/"><i class="fa fa-clock-o"></i> June 2, 2020</a></div></div></div></article><article class="jeg_post jeg_pl_sm format-standard"><div class="jeg_thumb"> <a href="https://middleeasy.com/boxing/floyd-mayweather-funeral-george/"><div class="thumbnail-container animate-lazy size-715 "><img width="120" height="86" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" class="lazyload wp-post-image" alt="Floyd Mayweather" data-src="https://middleeasy.com/wp-content/uploads/2020/06/pixlr-20200602011811988-copy-1400x733-1-120x86.jpg" data-sizes="auto" data-expand="700" /></div> </a></div><div class="jeg_postblock_content"><h3 class="jeg_post_title"> <a href="https://middleeasy.com/boxing/floyd-mayweather-funeral-george/">Floyd Mayweather Offers To Fund The Funeral Of George Floyd</a></h3><div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://middleeasy.com/boxing/floyd-mayweather-funeral-george/"><i class="fa fa-clock-o"></i> June 2, 2020</a></div></div></div></article><article class="jeg_post jeg_pl_sm format-standard"><div class="jeg_thumb"> <a href="https://middleeasy.com/ufc-news/white-reacts-jones-title/"><div class="thumbnail-container animate-lazy size-715 "><img width="120" height="86" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" class="lazyload wp-post-image" alt="White" data-src="https://middleeasy.com/wp-content/uploads/2020/05/pjimage-6--120x86.jpg" data-sizes="auto" data-expand="700" /></div> </a></div><div class="jeg_postblock_content"><h3 class="jeg_post_title"> <a href="https://middleeasy.com/ufc-news/white-reacts-jones-title/">Dana White Reacts To Jon Jones Vacating Title: &#8216;He&#8217;s Made Enough Money&#8217;</a></h3><div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://middleeasy.com/ufc-news/white-reacts-jones-title/"><i class="fa fa-clock-o"></i> June 1, 2020</a></div></div></div></article><article class="jeg_post jeg_pl_sm format-standard"><div class="jeg_thumb"> <a href="https://middleeasy.com/mma-news/israel-adesanya-speech/"><div class="thumbnail-container animate-lazy size-715 "><img width="120" height="86" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" class="lazyload wp-post-image" alt="Israel Adesanya, via @Stylebender on Instagram" data-src="https://middleeasy.com/wp-content/uploads/2020/06/pjimage-23--120x86.jpg" data-sizes="auto" data-expand="700" /></div> </a></div><div class="jeg_postblock_content"><h3 class="jeg_post_title"> <a href="https://middleeasy.com/mma-news/israel-adesanya-speech/">&#8220;Pissed Off&#8221; Israel Adesanya Addresses Racism During Powerful Speech at Auckland Rally</a></h3><div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://middleeasy.com/mma-news/israel-adesanya-speech/"><i class="fa fa-clock-o"></i> June 1, 2020</a></div></div></div></article></div></div><div class='module-overlay'><div class='preloader_type preloader_dot'><div class="module-preloader jeg_preloader dot"> <span></span><span></span><span></span></div><div class="module-preloader jeg_preloader circle"><div class="jnews_preloader_circle_outer"><div class="jnews_preloader_circle_inner"></div></div></div><div class="module-preloader jeg_preloader square"><div class="jeg_square"><div class="jeg_square_inner"></div></div></div></div></div></div><div class="jeg_block_navigation"><div class='navigation_overlay'><div class='module-preloader jeg_preloader'><span></span><span></span><span></span></div></div></div> <script>var jnews_module_106469_1_5ed692d4b6ba5 = {"header_icon":"","first_title":"","second_title":"","url":"","header_type":"heading_6","header_background":"","header_secondary_background":"","header_text_color":"","header_line_color":"","header_accent_color":"","header_filter_category":"","header_filter_author":"","header_filter_tag":"","header_filter_text":"All","post_type":"post","content_type":"all","number_post":5,"post_offset":0,"unique_content":"disable","include_post":"","exclude_post":"","include_category":"","exclude_category":"","include_author":"","include_tag":"","exclude_tag":"","sort_by":"latest","date_format":"default","date_format_custom":"Y\/m\/d","excerpt_length":20,"excerpt_ellipsis":"...","force_normal_image_load":"","pagination_mode":"disable","pagination_nextprev_showtext":"","pagination_number_post":5,"pagination_scroll_limit":0,"boxed":"","boxed_shadow":"","el_id":"","el_class":"","scheme":"","column_width":"auto","title_color":"","accent_color":"","alt_color":"","excerpt_color":"","css":"","paged":1,"column_class":"jeg_col_1o3","class":"jnews_block_1"};</script> </div></div></div></div><div class="jeg_ad jeg_article jnews_article_bottom_ads"><div class='ads-wrapper '></div></div></div></div></div></div><div id="post-body-class" class="post-template-default single single-post postid-106469 single-format-standard wp-embed-responsive aawp-custom jeg_toggle_dark jeg_single_tpl_1 jnews jsc_normal elementor-default"></div></div><div class="post-ajax-overlay"><div class="preloader_type preloader_dot"><div class="newsfeed_preloader jeg_preloader dot"> <span></span><span></span><span></span></div><div class="newsfeed_preloader jeg_preloader circle"><div class="jnews_preloader_circle_outer"><div class="jnews_preloader_circle_inner"></div></div></div><div class="newsfeed_preloader jeg_preloader square"><div class="jeg_square"><div class="jeg_square_inner"></div></div></div></div></div></div><div class="footer-holder" id="footer" data-id="footer"><div class="jeg_footer jeg_footer_3 dark"><div class="jeg_footer_container jeg_container"><div class="jeg_footer_content"><div class="container"><div class="row"><div class="jeg_footer_primary clearfix"><div class="col-md-3 footer_column"><div class="footer_widget widget_text" id="text-8"><div class="textwidget"><p><img class="alignnone wp-image-55421" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20196%2054'%3E%3C/svg%3E" alt="MiddleEasy.com - MMA News" width="196" height="54" data-lazy-src="https://middleeasy.com/wp-content/uploads/2018/02/NewLogoLeftTrans-small.png" /><noscript><img class="alignnone wp-image-55421" src="https://middleeasy.com/wp-content/uploads/2018/02/NewLogoLeftTrans-small.png" alt="MiddleEasy.com - MMA News" width="196" height="54" /></noscript></p><p>Founded in 2009, MiddleEasy.com provides <strong>UFC News</strong> daily <strong>MMA News</strong>, Fight Results, <strong>Street Fights</strong>, MM Rumors, Interviews, Analysis and complete coverage of the MMA sports.</p><div class="footer-social-wrap td-social-style-2"></div></div></div><div class="footer_widget widget_jnews_social" id="jnews_social-2"><div class="jeg_footer_heading jeg_footer_heading_1"><h3 class="jeg_footer_title"><span>Follow Us</span></h3></div><div class="jeg_social_wrap "><div class="socials_widget rounded"> <a href="https://www.facebook.com/middleeasydotcom/" target="_blank" class="jeg_facebook"> <i class="fa fa-facebook"></i> </a><a href="https://twitter.com/MiddleEasy" target="_blank" class="jeg_twitter"> <i class="fa fa-twitter"></i> </a><a href="https://www.youtube.com/middleeasytv/" target="_blank" class="jeg_youtube"> <i class="fa fa-youtube-play"></i> </a><a href="https://www.instagram.com/middleeasy/" target="_blank" class="jeg_instagram"> <i class="fa fa-instagram"></i> </a></div><style scoped></style></div></div></div><div class="col-md-3 footer_column"><div class="footer_widget widget_text" id="text-9"><div class="jeg_footer_heading jeg_footer_heading_1"><h3 class="jeg_footer_title"><span>Trending Topics</span></h3></div><div class="textwidget"><ul><li><a href="https://middleeasy.com/mma-news/">MMA News</a></li><li><a href="https://middleeasy.com/ufc-news/">UFC News</a></li><li><a href="https://middleeasy.com/tag/jon-jones/">Jon Jones News</a></li><li><a href="https://middleeasy.com/tag/ronda-rousey/">Ronda Rousey News</a></li><li><a href="https://middleeasy.com/tag/cris-cyborg/">Cris Cyborg News</a></li><li><a href="https://middleeasy.com/tag/nate-diaz/">Nate Diaz News</a></li><li><a href="https://middleeasy.com/tag/conor-mcGregor/">Conor McGregor News</a></li><li><a href="https://middleeasy.com/tag/georges-st-pierre/">Georges St. Pierre News</a></li><li><a href="https://middleeasy.com/street-fights/">Street MMA</a></li><li><a href="https://middleeasy.com/tag/khabib-nurmagomedov/">Khabib Nurmagomedov News</a></li><li><a href="https://mmahits.com/tag/joanna-jedrzejczyk/">Joanna Jedrzejczyk News</a></li><li><a href="https://middleeasy.com/tag/rose-namajunas/">Rose Namajunas News</a></li><li><a href="https://middleeasy.com/tag/holly-holm/">Holly Holm News</a></li></ul></div></div></div><div class="col-md-3 footer_column"></div><div class="col-md-3 footer_column"></div></div></div></div></div><div class="jeg_footer_bottom clearfix"><div class="container"><div class="footer_right"><ul class="jeg_menu_footer"><li id="menu-item-64120" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-64120"><a href="https://middleeasy.com/about-middleeasy/">About</a></li><li id="menu-item-100862" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-100862"><a href="https://middleeasy.com/syndication/">Syndication</a></li><li id="menu-item-64313" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-64313"><a href="https://middleeasy.com/writers-wanted/">Writers Wanted</a></li><li id="menu-item-64121" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-64121"><a href="https://middleeasy.com/advertise/">Advertise</a></li><li id="menu-item-64122" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-64122"><a href="https://middleeasy.com/contact-us/">Contact</a></li><li id="menu-item-101637" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-101637"><a href="https://middleeasy.com/scholarships/">Scholarship</a></li><li id="menu-item-64307" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-64307"><a href="https://middleeasy.com/dmca-policy/">DMCA Policy</a></li><li id="menu-item-64123" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-64123"><a href="https://middleeasy.com/privacy-policy/">Privacy Policy</a></li></ul></div><p class="copyright"> © Copyright 2020 <a href="https://middleeasy.com/">MiddleEasy.com</a>, All rights reserved. <br> Made with ♡ in NYC by <a href="https://hattanmedia.com/">Hattan Media New York</a></p></div></div></div></div></div><div class="jscroll-to-top"> <a href="#back-to-top" class="jscroll-to-top_link"><i class="fa fa-angle-up"></i></a></div></div><div id="jeg_off_canvas" class="normal"> <a href="#" class="jeg_menu_close"><i class="jegicon-cross"></i></a><div class="jeg_bg_overlay"></div><div class="jeg_mobile_wrapper"><div class="nav_wrap"><div class="item_main"><div class="jeg_aside_item jeg_search_wrapper jeg_search_no_expand square"> <a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a><form action="https://middleeasy.com/" method="get" class="jeg_search_form" target="_top"> <input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off"> <button type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button></form><div class="jeg_search_result jeg_search_hide with_result"><div class="search-result-wrapper"></div><div class="search-link search-noresult"> No Result</div><div class="search-link search-all-button"> <i class="fa fa-search"></i> View All Result</div></div></div><div class="jeg_aside_item"><ul class="jeg_mobile_menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-104755"><a href="https://middleeasy.com/mma-news/">MMA News</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62830"><a href="https://middleeasy.com/category/mma-rumors/">Rumors</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-41986"><a href="https://middleeasy.com/category/street-fights/">Street Fights</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-93739"><a href="https://middleeasy.com/reviews/">MMA Reviews</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-63038"><a href="https://middleeasy.com/category/videos/">Videos</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-64101"><a href="https://middleeasy.com/category/top-lists/">MMA Top Lists</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-64050"><a href="#">More</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62863"><a href="https://middleeasy.com/category/podcast/">Podcast</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-64102"><a href="https://middleeasy.com/category/science/">Science</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62832"><a href="https://middleeasy.com/category/entertainment/">Entertainment</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62831"><a href="https://middleeasy.com/category/gaming/">Gaming</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-64117"><a href="https://middleeasy.com/category/trump-mma/">Trump MMA</a></li></ul></li></ul></div></div><div class="item_bottom"><div class="jeg_aside_item socials_widget nobg"> <a href="https://www.facebook.com/middleeasydotcom/" target='_blank' class="jeg_facebook"><i class="fa fa-facebook"></i> </a><a href="https://twitter.com/MiddleEasy" target='_blank' class="jeg_twitter"><i class="fa fa-twitter"></i> </a><a href="https://www.youtube.com/middleeasytv/" target='_blank' class="jeg_youtube"><i class="fa fa-youtube-play"></i> </a><a href="https://www.instagram.com/middleeasy/" target='_blank' class="jeg_instagram"><i class="fa fa-instagram"></i> </a></div><div class="jeg_aside_item jeg_aside_copyright"><p>© Copyright 2020 <a href="https://middleeasy.com/">MiddleEasy.com</a>, All rights reserved. <br> Made with ♡ in NYC by <a href="https://hattanmedia.com/">Hattan Media New York</a></p></div></div></div></div></div><div class="essb_links essb_displayed_sidebar essb_share essb_sidebar_transition essb_sidebar_transition_slide essb_template_rainbow-retina essb_340921087 essb_button_animation_legacy1 essb_mobile_hidden essb_tablet_hidden print-no" id="essb_displayed_sidebar_340921087" data-essb-postid="106469" data-essb-position="sidebar" data-essb-button-style="icon" data-essb-template="rainbow-retina" data-essb-counter-pos="hidden" data-essb-url="https://middleeasy.com/boxing/floyd-mayweather-funeral-george/" data-essb-twitter-url="https://middleeasy.com/boxing/floyd-mayweather-funeral-george/" data-essb-instance="340921087"><ul class="essb_links_list essb_force_hide_name essb_force_hide"><li class="essb_item essb_link_facebook nolightbox"> <a href="https://www.facebook.com/sharer/sharer.php?u=https://middleeasy.com/boxing/floyd-mayweather-funeral-george/&t=Floyd+Mayweather+Offers+To+Fund+The+Funeral+Of+George+Floyd" title="" onclick="essb.window(&#39;https://www.facebook.com/sharer/sharer.php?u=https://middleeasy.com/boxing/floyd-mayweather-funeral-george/&t=Floyd+Mayweather+Offers+To+Fund+The+Funeral+Of+George+Floyd&#39;,&#39;facebook&#39;,&#39;340921087&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox"><span class="essb_icon essb_icon_facebook"></span><span class="essb_network_name essb_noname"></span></a></li><li class="essb_item essb_link_twitter nolightbox"> <a href="#" title="" onclick="essb.window(&#39;https://twitter.com/intent/tweet?text=Floyd+Mayweather+Offers+To+Fund+The+Funeral+Of+George+Floyd&amp;url=https://middleeasy.com/boxing/floyd-mayweather-funeral-george/&amp;counturl=https://middleeasy.com/boxing/floyd-mayweather-funeral-george/&amp;related=MiddleEasy&amp;via=MiddleEasy&amp;hashtags=Boxing,floydmayweather,GeorgeFloyd,JusticeForGeorgeFloyd&#39;,&#39;twitter&#39;,&#39;340921087&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox"><span class="essb_icon essb_icon_twitter"></span><span class="essb_network_name essb_noname"></span></a></li><li class="essb_item essb_link_reddit nolightbox"> <a href="https://reddit.com/submit?url=https://middleeasy.com/boxing/floyd-mayweather-funeral-george/&amp;title=Floyd+Mayweather+Offers+To+Fund+The+Funeral+Of+George+Floyd" title="" onclick="essb.window(&#39;http://reddit.com/submit?url=https://middleeasy.com/boxing/floyd-mayweather-funeral-george/&amp;title=Floyd+Mayweather+Offers+To+Fund+The+Funeral+Of+George+Floyd&#39;,&#39;reddit&#39;,&#39;340921087&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox"><span class="essb_icon essb_icon_reddit"></span><span class="essb_network_name essb_noname"></span></a></li><li class="essb_item essb_link_flipboard nolightbox"> <a href="https://share.flipboard.com/bookmarklet/popout?url=https://middleeasy.com/boxing/floyd-mayweather-funeral-george/&title=Floyd+Mayweather+Offers+To+Fund+The+Funeral+Of+George+Floyd" title="" onclick="essb.window(&#39;https://share.flipboard.com/bookmarklet/popout?url=https://middleeasy.com/boxing/floyd-mayweather-funeral-george/&title=Floyd+Mayweather+Offers+To+Fund+The+Funeral+Of+George+Floyd&#39;,&#39;flipboard&#39;,&#39;340921087&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox"><span class="essb_icon essb_icon_flipboard"></span><span class="essb_network_name essb_noname"></span></a></li><li class="essb_item essb_link_more nolightbox"> <a href="#" title="" onclick="essb.toggle_more(&#39;340921087&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox"><span class="essb_icon essb_icon_more"></span><span class="essb_network_name essb_noname"></span></a></li><li class="essb_item essb_link_linkedin nolightbox essb_after_more"> <a href="https://www.linkedin.com/shareArticle?mini=true&amp;ro=true&amp;trk=EasySocialShareButtons&amp;title=Floyd+Mayweather+Offers+To+Fund+The+Funeral+Of+George+Floyd&amp;url=https://middleeasy.com/boxing/floyd-mayweather-funeral-george/" title="" onclick="essb.window(&#39;https://www.linkedin.com/shareArticle?mini=true&amp;ro=true&amp;trk=EasySocialShareButtons&amp;title=Floyd+Mayweather+Offers+To+Fund+The+Funeral+Of+George+Floyd&amp;url=https://middleeasy.com/boxing/floyd-mayweather-funeral-george/&#39;,&#39;linkedin&#39;,&#39;340921087&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox"><span class="essb_icon essb_icon_linkedin"></span><span class="essb_network_name essb_noname"></span></a></li><li class="essb_item essb_link_pinterest nolightbox essb_after_more"> <a href="#" title="" onclick="essb.pinterest_picker(&#39;340921087&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox"><span class="essb_icon essb_icon_pinterest"></span><span class="essb_network_name essb_noname"></span></a></li><li class="essb_item essb_link_less nolightbox essb_after_more"> <a href="#" title="" onclick="essb.toggle_less(&#39;340921087&#39;); return false;" target="_blank" rel="nofollow"><span class="essb_icon essb_icon_less"></span><span class="essb_network_name"></span></a></li></ul></div><style>.aawp .aawp-product--horizontal .aawp-product__description{display:block}</style> <div class="jeg_read_progress_wrapper"></div><script type='text/javascript'>/* <![CDATA[ */ var superpwa_sw = {"url":"\/OneSignalSDKWorker.js.php"}; /* ]]> */</script> <script type='text/javascript'>/* <![CDATA[ */ var jnewsoption = {"popup_script":"magnific","single_gallery":"","ismobile":"","isie":"","sidefeed_ajax":"","language":"en_US","module_prefix":"jnews_module_ajax_","live_search":"1","postid":"106469","isblog":"1","admin_bar":"0","follow_video":"","follow_position":"top_right","rtl":"0","gif":"","lang":{"invalid_recaptcha":"Invalid Recaptcha!","empty_username":"Please enter your username!","empty_email":"Please enter your email!","empty_password":"Please enter your password!"},"recaptcha":"0","site_slug":"\/","site_domain":"middleeasy.com"}; /* ]]> */</script> <!--[if lt IE 9]>
<script type='text/javascript' src='https://middleeasy.com/wp-content/themes/jnews/assets/js/html5shiv.min.js?ver=6.5.4'></script>
<![endif]--> <div class="jeg_ad jnews_mobile_sticky_ads "></div><script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"NewsArticle","mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/middleeasy.com\/boxing\/floyd-mayweather-funeral-george\/"},"dateCreated":"2020-06-02 09:51:31","datePublished":"2020-06-02 09:51:31","dateModified":"2020-06-02 14:05:36","url":"https:\/\/middleeasy.com\/boxing\/floyd-mayweather-funeral-george\/","headline":"Floyd Mayweather Offers To Fund The Funeral Of George Floyd","name":"Floyd Mayweather Offers To Fund The Funeral Of George Floyd","articleBody":"The world is immensely complicated right now, in the wake of the death of George Floyd. Now boxing great <strong>Floyd Mayweather<\/strong> has offered his assistance to George's family during this difficult time.\r\n\r\nIt has been just over a month since Minneapolis police allegedly caused the death of 59-year old George Floyd. This has resulted in <strong>a ton of tension throughout the nation<\/strong>, as riots and protests have broken out throughout the country. This has even caused various fighters to <a href=\"https:\/\/middleeasy.com\/mma-news\/jon-jones-albuquerque-protesters\/\">stop vandalism<\/a>, <a href=\"https:\/\/middleeasy.com\/mma-news\/israel-adesanya-speech\/\">protest<\/a>, or try to <a href=\"https:\/\/middleeasy.com\/mma-news\/chuck-liddell-fights-rally\/\">keep the peace<\/a>.\r\n\r\nhttps:\/\/www.instagram.com\/p\/B9QSSGsl5Po\/?igshid=11zc1mamzhhr\r\n\r\nNow another member of the combat sports community is doing his part to help out during this tough time. According to <a href=\"https:\/\/www.espn.com\/boxing\/story\/_\/id\/29252860\/floyd-mayweather-pay-george-floyd-funeral-services\">reports<\/a>, world champion boxer Floyd Mayweather has stepped up to <strong>cover the costs of the funeral for George Floyd.<\/strong> It was not something he wanted to bring attention to, but his manager Leonard Ellerbe confirmed the rumors.\r\n<blockquote class=\"pullquote align-center\">\"He\u2019ll probably get mad at me for saying that, but yes, (Mayweather) is definitely paying for the funeral,\u201d he said. \u201cFloyd has done these kind of things over the last 20 years.\"<\/blockquote>\r\nThis is <strong>a massively kind gesture from Floyd,<\/strong> without a doubt. It can be said with a fair degree of certainty, that George's family has been having a wild time since the tragic loss of their family member, and the subsequent media storm. It must be at least some level of relief to know that this will be taken care of.\r\n\r\nThere have been some pretty big critics of some of the things Floyd Mayweather has done over the years, and rightfully so. However this is not the first time that he has done something to this effect. Nevertheless it is important to note the times that <strong>he goes above and beyond to support the culture<\/strong> in a time of need.","author":{"@type":"Person","name":"Derek Hall","url":"https:\/\/middleeasy.com\/author\/derekhall\/","sameAs":["http:\/\/fitnessvolt.com\/author\/derek","twitter.com\/aquabuddha7"]},"articleSection":["Boxing","Featured"],"image":{"@type":"ImageObject","url":"https:\/\/middleeasy.com\/wp-content\/uploads\/2020\/06\/pixlr-20200602011811988-copy-1400x733-1.jpg","width":1400,"height":733},"publisher":{"@type":"Organization","name":"MiddleEasy: MMA News","url":"https:\/\/middleeasy.com","logo":{"@type":"ImageObject","url":"https:\/\/middleeasy.com\/wp-content\/uploads\/2020\/06\/middleeasy-logo.png"},"sameAs":["https:\/\/www.facebook.com\/middleeasydotcom\/","https:\/\/twitter.com\/MiddleEasy","https:\/\/www.youtube.com\/middleeasytv\/","https:\/\/www.instagram.com\/middleeasy\/"]}}</script> <script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"hentry","entry-title":"Floyd Mayweather Offers To Fund The Funeral Of George Floyd","published":"2020-06-02 09:51:31","updated":"2020-06-02 14:05:36"}</script> <script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"item":{"@id":"https:\/\/middleeasy.com","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@id":"https:\/\/middleeasy.com\/category\/boxing\/","name":"Boxing"}},{"@type":"ListItem","position":3,"item":{"@id":"https:\/\/middleeasy.com","name":"Home"}},{"@type":"ListItem","position":4,"item":{"@id":"https:\/\/middleeasy.com\/category\/boxing\/","name":"Boxing"}}]}</script> <script>window.lazyLoadOptions={elements_selector:"img[data-lazy-src],.rocket-lazyload",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,callback_loaded:function(element){if(element.tagName==="IFRAME"&&element.dataset.rocketLazyload=="fitvidscompatible"){if(element.classList.contains("lazyloaded")){if(typeof window.jQuery!="undefined"){if(jQuery.fn.fitVids){jQuery(element).parent().fitVids()}}}}}};window.addEventListener('LazyLoad::Initialized',function(e){var lazyLoadInstance=e.detail.instance;if(window.MutationObserver){var observer=new MutationObserver(function(mutations){var image_count=0;var iframe_count=0;var rocketlazy_count=0;mutations.forEach(function(mutation){for(i=0;i<mutation.addedNodes.length;i++){if(typeof mutation.addedNodes[i].getElementsByTagName!=='function'){return}
if(typeof mutation.addedNodes[i].getElementsByClassName!=='function'){return}
images=mutation.addedNodes[i].getElementsByTagName('img');is_image=mutation.addedNodes[i].tagName=="IMG";iframes=mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe=mutation.addedNodes[i].tagName=="IFRAME";rocket_lazy=mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count+=images.length;iframe_count+=iframes.length;rocketlazy_count+=rocket_lazy.length;if(is_image){image_count+=1}
if(is_iframe){iframe_count+=1}}});if(image_count>0||iframe_count>0||rocketlazy_count>0){lazyLoadInstance.update()}});var b=document.getElementsByTagName("body")[0];var config={childList:!0,subtree:!0};observer.observe(b,config)}},!1)</script><script data-no-minify="1" async src="https://middleeasy.com/wp-content/plugins/wp-rocket/assets/js/lazyload/12.0/lazyload.min.js"></script><script src="https://middleeasy.com/wp-content/cache/min/1/752dcf3142e7356923fe97a70444f91d.js" data-minify="1" defer></script></body></html>
